Documentation updates restored
We have worked through the documentation update backlog and re-run all updates that were dropped during the disruption. New deploys and content updates are processing normally. We are continuing to monitor recovery before resolving the incident.
Resolved
Documentation updates restored
We have worked through the documentation update backlog and re-run all updates that were dropped during the disruption. New deploys and content updates are processing normally. We are continuing to monitor recovery before resolving the incident.
Monitoring
Core platform services are operational, but documentation updates, deploys, and commit checks remain delayed due to processing queue backlogs.
We are actively draining the backlogs and restoring normal processing capacity. New updates may continue to experience delays during recovery. We’ll provide another update as processing returns to normal.
Monitoring
Database availability has been restored and all replica members are healthy. We are progressively scaling impacted services back up.
Dashboard, documentation updates, search, MCP, and Assistant are recovering but may experience intermittent errors or elevated latency. Some authenticated sites remain affected by a separate DNS issue. We’re monitoring stability and continuing restoration.
Identified
We've identified the underlying database issue and database availability has been restored. We are now scaling impacted services back up in a controlled sequence while monitoring stability.
Dashboard, documentation updates and deploys, search, MCP, GitHub Actions, Assistant, and authenticated documentation sites remain intermittently unavailable. We’ll provide another update as recovery progresses.
Investigating
The services that were previously restored are experiencing issues again. The following are currently unavailable:
Dashboard
Documentation updates - deploys and content updates are not going through
Doc search
MCP
Assistant
Authenticated documentation sites
GitHub Actions
Investigating
The following services have been restored and are operating normally:
Dashboard
Doc search
Assistant
Authenticated documentation sites
We're continuing to work on restoring the remaining affected services:
Documentation updates - deploys and content updates are not going through
MCP - unavailable
Investigating
We're currently investigating an issue affecting the hot path for database requests. This is impacting the following services:
Authenticated documentation sites - unavailable
Dashboard - unavailable
Documentation updates - deploys and content updates are not going through
Doc search - unavailable
Assistant - unavailable
MCP - unavailable
Unauthenticated (public) documentation sites remain fully available and are not affected by this incident