On-site Assistant Usage is Causing Pages to 500
Resolved·Partial outage
Postmortem

Between 1:19 PM PST - 01:43 PM PST Sending messages to the AI assistant on Mintlify documentation sites is currently causing 500s when asking questions. This was due to an internal backend route for being modified which lead to parsing errors on the client.

To mitigate this, we updated the client to handle the new payload type and resolved the issue. We added both integration tests in our staging environment and live synthetic tests to prevent this in the future.

Timeline
  • 10:44 AM PST: Bad pull request merged into staging

  • 12:45 PM PST: Pull request promoted to production

  • 1:19 PM PST: Incident Reported

  • 1:45 PM PST: Incident Resolved

Thu, Dec 11, 2025, 10:30 PM
(1 week ago)
·
Affected components
Updates

Resolved

Postmortem

Between 1:19 PM PST - 01:43 PM PST Sending messages to the AI assistant on Mintlify documentation sites is currently causing 500s when asking questions. This was due to an internal backend route for being modified which lead to parsing errors on the client.

To mitigate this, we updated the client to handle the new payload type and resolved the issue. We added both integration tests in our staging environment and live synthetic tests to prevent this in the future.

Timeline
  • 10:44 AM PST: Bad pull request merged into staging

  • 12:45 PM PST: Pull request promoted to production

  • 1:19 PM PST: Incident Reported

  • 1:45 PM PST: Incident Resolved

Thu, Dec 11, 2025, 10:30 PM

Resolved

We deployed a fix and all assistant interactions should now no longer cause 500 issues.

We will be updating with a post-mortem shortly.

Thu, Dec 11, 2025, 09:43 PM(47 minutes earlier)

Identified

Sending messages to the AI assistant on Mintlify documentation sites is currently causing 500s. We have identified the issue and are deploying a fix.

Thu, Dec 11, 2025, 09:19 PM(23 minutes earlier)
Powered by