Intermittent Latency & Timeouts
Resolved·Degraded performance

A huge spike in client page traffic caused dashboard page latencies to increase due to the increased CPU load.

We migrated client routes to a separate cluster to resolve this issue

Wed, Jan 14, 2026, 06:15 PM
(2 weeks ago)
·
Affected components
Updates
Dashboard
Updates

Resolved

A huge spike in client page traffic caused dashboard page latencies to increase due to the increased CPU load.

We migrated client routes to a separate cluster to resolve this issue

Wed, Jan 14, 2026, 06:15 PM

Investigating

We're experiencing intermittent increased latency and timeouts across our production systems. The team is investigating now and will update this status page accordingly.

Wed, Jan 14, 2026, 05:45 PM(30 minutes earlier)
Powered by