Slowdown on queued deployment updates
Resolved·Degraded performance

The queue has remained relatively clear and we are closely monitoring it for any future deviations from the norm.

Updates should be processed as normally.

Wed, Jan 21, 2026, 11:33 PM
(1 week ago)
·
Affected components
Updates
Updates

Resolved

The queue has remained relatively clear and we are closely monitoring it for any future deviations from the norm.

Updates should be processed as normally.

Wed, Jan 21, 2026, 11:33 PM

Monitoring

The queue is clear and we are scaling down our number of update workers, but keeping a close eye on the number of queued and active jobs.

All updates should have been resumed

Wed, Jan 21, 2026, 10:56 PM(36 minutes earlier)

Monitoring

We've experienced a large bursts of updates that has caused our update worker pool to have some delays when processing jobs. In response, we've massively scaled up the pool and are closely monitoring the number of active and waiting jobs.

Impact: Update jobs may take longer than normal to be processed, no retries are necessary - all jobs will remain queued until processed.

Wed, Jan 21, 2026, 10:44 PM(12 minutes earlier)
Powered by