Resolved
The temporary spike in queued redeployments has been cleared, and updates have returned to processing normally again.
We will continue monitoring to redeployments.
Investigating
We've experience a large spike in traffic to update documentation sites and are seeing deployment updates taking longer than usual.
We’re actively increasing workflow capacity and clearing the backlog to restore normal processing times.