Resolved
We investigated the reports and determined there was no underlying system issue. The affected cases were isolated and are being resolved. Preview generations and deployment updates are operating normally.
Investigating
We have received multiple reports of content changes not propogating with updates and pull requests not being picked up for preview site generations and are investigating the cause.