Resolved
GitHub has resolved the webhook degradation. Preview builds and redeploys should now function normally.
Investigating
We are seeing intermittent issues where preview builds and redeploys are not being triggered automatically. This has been traced to an ongoing GitHub webhooks degradation that is affecting a subset of webhook deliveries.
While this issue persists, some documentation changes from commits or pull requests may not deploy automatically. Customers can trigger a manual redeploy to publish updates, or contact support for assistance.
You can monitor GitHub’s status here: https://www.githubstatus.com/