Resolved
The redeployment queue has been cleared and job times have returned to normal. We are continuing to investigate the underlying cause.
Investigating
Redeployments are taking much longer than expected and are currently backed up. We’re actively working to clear the queue and restore normal speeds while investigating the root cause.